$re = '/\*{2}Start\*{2}(.*?)\*{2}End\*{2}/';
$str = 'za e e**Start**Good1**End**ds dq**Start**Good2**End**sds df';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);