package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*{2}Start\*{2}(.*?)\*{2}End\*{2}`)
var str = `za e e**Start**Good1**End**ds dq**Start**Good2**End**sds df`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}