#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]+(?:[_ ][a-z]+)*$"
Local $sString = "ag_b_cf_ajk" & @CRLF & _
"zva b c de" & @CRLF & _
"hh_b opxop a_b" & @CRLF & _
"axz_be" & @CRLF & _
"axz be" & @CRLF & _
"" & @CRLF & _
"axz_be_j" & @CRLF & _
"axz be j"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")