re = /^[a-z]+(?:[_ ][a-z]+)*$/m
str = 'ag_b_cf_ajk
zva b c de
hh_b opxop a_b
axz_be
axz be
axz_be_j
axz be j'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end