use strict;
my $str = 'ag_b_cf_ajk
zva b c de
hh_b opxop a_b
axz_be
axz be
axz_be_j
axz be j';
my $regex = qr/^[a-z]+(?:[_ ][a-z]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}