package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+(?:[_ ][a-z]+)*$`)
var str = `ag_b_cf_ajk
zva b c de
hh_b opxop a_b
axz_be
axz be
axz_be_j
axz be j`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}