#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\s*|\G)\s*(?:,\s*)?\K(\b\d{1,2}\b)(?=(?:\s*(?:,\s*)?\b\d{1,2}\b)*$)"
Local $sString = " 1" & @CRLF & _
" 1 2 3 3 4 5 7 17" & @CRLF & _
" 1, 2,3,11,74" & @CRLF & _
"1,11,14, 15" & @CRLF & _
"" & @CRLF & _
"111, 101" & @CRLF & _
"1 2 3 a" & @CRLF & _
"1, 25, 5.0 " & @CRLF & _
"1,, 7, 80" & @CRLF & _
"1,11,14,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")