$re = '/(?:^\s*|\G)\s*(?:,\s*)?\K(\b\d{1,2}\b)(?=(?:\s*(?:,\s*)?\b\d{1,2}\b)*$)/m';
$str = ' 1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
111, 101
1 2 3 a
1, 25, 5.0
1,, 7, 80
1,11,14,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);