re = /(?:^\s*|\G)\s*(?:,\s*)?\K(\b\d{1,2}\b)(?=(?:\s*(?:,\s*)?\b\d{1,2}\b)*$)/m
str = ' 1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
111, 101
1 2 3 a
1, 25, 5.0
1,, 7, 80
1,11,14,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end