import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\s*|\\G)\\s*(?:,\\s*)?\\K(\\b\\d{1,2}\\b)(?=(?:\\s*(?:,\\s*)?\\b\\d{1,2}\\b)*$)";
final String string = " 1\n"
+ " 1 2 3 3 4 5 7 17\n"
+ " 1, 2,3,11,74\n"
+ "1,11,14, 15\n\n"
+ "111, 101\n"
+ "1 2 3 a\n"
+ "1, 25, 5.0 \n"
+ "1,, 7, 80\n"
+ "1,11,14,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}