#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)(?<!10)\.(\d+)(?<!192\.168)(?<!172\.(1[0-6]|2\d|3[0-1]))\.(\d+)\.(\d+)"
Local $sString = "74.125.226.134" & @CRLF & _
"10.0.1.1" & @CRLF & _
"172.16.0.0" & @CRLF & _
"172.31.0.1" & @CRLF & _
"172.32.0.0" & @CRLF & _
"192.168.10.1" & @CRLF & _
"104.44.81.79"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")