import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(?<!10)\\.(\\d+)(?<!192\\.168)(?<!172\\.(1[0-6]|2\\d|3[0-1]))\\.(\\d+)\\.(\\d+)";
final String string = "74.125.226.134\n"
+ "10.0.1.1\n"
+ "172.16.0.0\n"
+ "172.31.0.1\n"
+ "172.32.0.0\n"
+ "192.168.10.1\n"
+ "104.44.81.79";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}