re = /(\d+)(?<!10)\.(\d+)(?<!192\.168)(?<!172\.(1[0-6]|2\d|3[0-1]))\.(\d+)\.(\d+)/
str = '74.125.226.134
10.0.1.1
172.16.0.0
172.31.0.1
172.32.0.0
192.168.10.1
104.44.81.79'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end