use strict;
my $str = '74.125.226.134
10.0.1.1
172.16.0.0
172.31.0.1
172.32.0.0
192.168.10.1
104.44.81.79';
my $regex = qr/(\d+)(?<!10)\.(\d+)(?<!192\.168)(?<!172\.(1[0-6]|2\d|3[0-1]))\.(\d+)\.(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}