#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<message_type>[^.]query|response)\:"
Local $sString = "Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 26818 from 10.190.48.12#13258: view none: query: v-ipr-webproxy.i.np2.navy.mil IN A + (10.190.44.87%0)" & @CRLF & _
"Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 57035 to 10.190.48.12#13258: [NOERROR qr,aa,rd] response: v-ipr-webproxy.i.np2.navy.mil" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")