import Foundation
let pattern = #"(?P<message_type>[^.]query|response)\:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 26818 from 10.190.48.12#13258: view none: query: v-ipr-webproxy.i.np2.navy.mil IN A + (10.190.44.87%0)
Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 57035 to 10.190.48.12#13258: [NOERROR qr,aa,rd] response: v-ipr-webproxy.i.np2.navy.mil
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)