package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<message_type>[^.]query|response)\:`)
var str = `Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 26818 from 10.190.48.12#13258: view none: query: v-ipr-webproxy.i.np2.navy.mil IN A + (10.190.44.87%0)
Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 57035 to 10.190.48.12#13258: [NOERROR qr,aa,rd] response: v-ipr-webproxy.i.np2.navy.mil
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}