use strict;
my $str = 'Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 26818 from 10.190.48.12#13258: view none: query: v-ipr-webproxy.i.np2.navy.mil IN A + (10.190.44.87%0)
Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 57035 to 10.190.48.12#13258: [NOERROR qr,aa,rd] response: v-ipr-webproxy.i.np2.navy.mil
';
my $regex = qr/(?P<message_type>[^.]query|response)\:/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}