import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![\\!@#\\$%\\^&\\*\\(\\)\\:\\\"\\<\\>\\?\\/,] [a-z][1-9])^(([A-Z]{1}[a-z0.']+)+( ?[A-Z]{1}[a-z0.]+))*";
final String string = "Smith\n"
+ "S0resen\n"
+ "O'Smith\n"
+ "Sm#ith\n"
+ "Smi3th\n"
+ "S0mith\n"
+ "smith\n"
+ "Mc Smith\n"
+ "Smith\n"
+ "Mc Muffin\n"
+ "McMutton\n"
+ "Mc Mutton\n"
+ "Mc mutton\n"
+ "O'riley\n"
+ "O'Riley";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}