import re
regex = re.compile(r"(?![\!@#\$%\^&\*\(\)\:\"\<\>\?\/,] [a-z][1-9])^(([A-Z]{1}[a-z0.']+)+( ?[A-Z]{1}[a-z0.]+))*", flags=re.MULTILINE)
test_str = ("Smith\n"
"S0resen\n"
"O'Smith\n"
"Sm#ith\n"
"Smi3th\n"
"S0mith\n"
"smith\n"
"Mc Smith\n"
"Smith\n"
"Mc Muffin\n"
"McMutton\n"
"Mc Mutton\n"
"Mc mutton\n"
"O'riley\n"
"O'Riley")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")