re = /(?![\!@#\$%\^&\*\(\)\:\"\<\>\?\/,] [a-z][1-9])^(([A-Z]{1}[a-z0.']+)+( ?[A-Z]{1}[a-z0.]+))*/m
str = 'Smith
S0resen
O\'Smith
Sm#ith
Smi3th
S0mith
smith
Mc Smith
Smith
Mc Muffin
McMutton
Mc Mutton
Mc mutton
O\'riley
O\'Riley'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end