const regex = /(?![\!@#\$%\^&\*\(\)\:\"\<\>\?\/,] [a-z][1-9])^(([A-Z]{1}[a-z0.']+)+( ?[A-Z]{1}[a-z0.]+))*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![\\!@#\\$%\\^&\\*\\(\\)\\:\\"\\<\\>\\?\\\/,] [a-z][1-9])^(([A-Z]{1}[a-z0.\']+)+( ?[A-Z]{1}[a-z0.]+))*', 'mg')
const str = `Smith
S0resen
O'Smith
Sm#ith
Smi3th
S0mith
smith
Mc Smith
Smith
Mc Muffin
McMutton
Mc Mutton
Mc mutton
O'riley
O'Riley`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}