using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{2},[A-Z0-9\W]*,[A-Z]{1},[A-Z0-9\W]*,[a-z\W]{6},[A-Za-z]*,[0-9\W]{11},[0-9]{10},[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*$";
string input = @"NS,FHS1,A,SHAMSTABRIZI AMIRHOSSEIN,en-usa,Create,33749-07305,9028356191,Message: closed.completed.all,Passed,Wed May 02 08:00:37 ADT 2018";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}