package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{2},[A-Z0-9\W]*,[A-Z]{1},[A-Z0-9\W]*,[a-z\W]{6},[A-Za-z]*,[0-9\W]{11},[0-9]{10},[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*$`)
var str = `NS,FHS1,A,SHAMSTABRIZI AMIRHOSSEIN,en-usa,Create,33749-07305,9028356191,Message: closed.completed.all,Passed,Wed May 02 08:00:37 ADT 2018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}