// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]{2},[A-Z0-9\W]*,[A-Z]{1},[A-Z0-9\W]*,[a-z\W]{6},[A-Za-z]*,[0-9\W]{11},[0-9]{10},[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*$").unwrap();
let string = "NS,FHS1,A,SHAMSTABRIZI AMIRHOSSEIN,en-usa,Create,33749-07305,9028356191,Message: closed.completed.all,Passed,Wed May 02 08:00:37 ADT 2018";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}