use strict;
my $str = 'Examples of fruits are apples, bananas, pears and grapes.
Examples of fruits are apples, bananas, grapes and pears.
Examples of fruits are bananas, pears and grapes.
Examples of fruits are apples, bananas, pears and pears.
Examples of fruitz are apples, bananas, pears and grapes.
Examples of fruits are kiwis, apples, bananas, pears and grapes.';
my $regex = qr/^Examples of fruits are (?>((?>bananas|apples|grapes|pears))(?![^.]*?\b\1\b)(?>,\s*+|\s++and\s++)?)++\.$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}