$re = '/^Examples of fruits are (?>((?>bananas|apples|grapes|pears))(?![^.]*?\b\1\b)(?>,\s*+|\s++and\s++)?)++\.$/m';
$str = 'Examples of fruits are apples, bananas, pears and grapes.
Examples of fruits are apples, bananas, grapes and pears.
Examples of fruits are bananas, pears and grapes.
Examples of fruits are apples, bananas, pears and pears.
Examples of fruitz are apples, bananas, pears and grapes.
Examples of fruits are kiwis, apples, bananas, pears and grapes.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);