import re
regex = re.compile(r"^Examples of fruits are (?>((?>bananas|apples|grapes|pears))(?![^.]*?\b\1\b)(?>,\s*+|\s++and\s++)?)++\.$", flags=re.MULTILINE)
test_str = ("Examples of fruits are apples, bananas, pears and grapes.\n\n"
"Examples of fruits are apples, bananas, grapes and pears.\n\n"
"Examples of fruits are bananas, pears and grapes.\n\n"
"Examples of fruits are apples, bananas, pears and pears.\n\n"
"Examples of fruitz are apples, bananas, pears and grapes.\n\n"
"Examples of fruits are kiwis, apples, bananas, pears and grapes.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")