using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script src=""common(?![\w\/]+config.js)";
string substitution = @"<script src=""//cdn.domain.common";
string input = @"<script src=""common/scripts/vendor.0.js""></script>
<script src=""common/scripts/all.0.js""></script>
<script src=""common/scripts/source/config.js""></script>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}