re = /<script src="common(?![\w\/]+config.js)/
str = '<script src="common/scripts/vendor.0.js"></script>
<script src="common/scripts/all.0.js"></script>
<script src="common/scripts/source/config.js"></script>'
subst = '<script src="//cdn.domain.common'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result