const regex = /<script src="common(?![\w\/]+config.js)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script src="common(?![\\w\\\/]+config.js)', 'g')
const str = `<script src="common/scripts/vendor.0.js"></script>
<script src="common/scripts/all.0.js"></script>
<script src="common/scripts/source/config.js"></script>`;
const subst = `<script src="//cdn.domain.common`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);