import Foundation
let pattern = #"<script src="common(?![\w\/]+config.js)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<script src="common/scripts/vendor.0.js"></script>
<script src="common/scripts/all.0.js"></script>
<script src="common/scripts/source/config.js"></script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<script src="//cdn.domain.common"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)