using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{5}(?!-\d{1,3}\b|-\d{5})(?:-\d{4})?\b";
string input = @"This is a sentence with multiple zip codes: 12345-1235 and 12345 and some false zip codes: 12345-123566, 12345-12";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}