re = /\b\d{5}(?!-\d{1,3}\b|-\d{5})(?:-\d{4})?\b/
str = 'This is a sentence with multiple zip codes: 12345-1235 and 12345 and some false zip codes: 12345-123566, 12345-12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end