import Foundation
let pattern = #"\b\d{5}(?!-\d{1,3}\b|-\d{5})(?:-\d{4})?\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a sentence with multiple zip codes: 12345-1235 and 12345 and some false zip codes: 12345-123566, 12345-12"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)