using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(2014)(.*?baloon.*)(?:2014)";
string input = @"2014.10.30: b
l
ah bl
a
h
2014.10.30: bfoo
lah
b
l
ah
2014.10.30: bart1
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: farb2
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: bom
lah
baloob
l
ah
etc";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}