# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(2014)(.*?baloon.*)(?:2014)"
test_str = ("2014.10.30: b\n"
"l\n"
"ah bl\n"
"a\n"
"h \n"
"2014.10.30: bfoo \n"
"lah \n"
"b \n"
"l \n"
"ah \n"
"2014.10.30: bart1 \n"
"lah \n"
"baloon \n"
"l \n"
"ah \n"
"2014.10.30: carb \n"
"lah \n"
"b \n"
"l \n"
"ah \n"
"2014.10.30: farb2 \n"
"lah \n"
"baloon \n"
"l \n"
"ah \n"
"2014.10.30: carb \n"
"lah \n"
"b \n"
"l \n"
"ah \n"
"2014.10.30: bom \n"
"lah \n"
"baloob \n"
"l \n"
"ah \n"
"etc")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.