$re = '/(2014)(.*?baloon.*)(?:2014)/msi';
$str = '2014.10.30: b
l
ah bl
a
h
2014.10.30: bfoo
lah
b
l
ah
2014.10.30: bart1
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: farb2
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: bom
lah
baloob
l
ah
etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);