package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?msi)(2014)(.*?baloon.*)(?:2014)`)
var str = `2014.10.30: b
l
ah bl
a
h
2014.10.30: bfoo
lah
b
l
ah
2014.10.30: bart1
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: farb2
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: bom
lah
baloob
l
ah
etc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}