import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "i18\\s*\\(\\s*['\"](.+)['\"]\\,.*\\)";
final String string = "i18('Grant (\\'%s\\') access to ALL users to feature: ', permission.toUpperCase());\n\n"
+ "alert(i18(\"These users already :\") exist and were:\") ', not added:\") + :\") ) xxx + \"\\n\\n\" + msg ); \n\n"
+ " var msg;\n"
+ " if (permission == 'none') {\n"
+ " msg = i18('This action will remove the rights for \\'%s\\' from feature: ', userName);\n"
+ " } else if (permission == 'complete') { \n"
+ " msg = i18('Grant ALL rights for \\'%s\\' to feature: ', userName);\n"
+ " } else { \n"
+ " msg = i18('Grant (\\'%s\\') access for \\'%s\\' to feature: ', [permission.toUpperCase(), userName]);\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}