import Foundation
let pattern = #"i18\s*\(\s*['"](.+)['"]\,.*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
i18('Grant (\'%s\') access to ALL users to feature: ', permission.toUpperCase());
alert(i18("These users already :") exist and were:") ', not added:") + :") ) xxx + "\n\n" + msg );
var msg;
if (permission == 'none') {
msg = i18('This action will remove the rights for \'%s\' from feature: ', userName);
} else if (permission == 'complete') {
msg = i18('Grant ALL rights for \'%s\' to feature: ', userName);
} else {
msg = i18('Grant (\'%s\') access for \'%s\' to feature: ', [permission.toUpperCase(), userName]);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)