re = /i18\s*\(\s*['"](.+)['"]\,.*\)/m
str = 'i18(\'Grant (\\\'%s\\\') access to ALL users to feature: \', permission.toUpperCase());
alert(i18("These users already :") exist and were:") \', not added:") + :")  ) xxx + "\\n\\n" + msg ); 	
					var msg;
					if (permission == \'none\') {
						msg = i18(\'This action will remove the rights for \\\'%s\\\' from feature: \', userName);
					} else if (permission == \'complete\') {						
						msg = i18(\'Grant ALL rights for \\\'%s\\\' to feature: \', userName);
					} else {	
						msg = i18(\'Grant (\\\'%s\\\') access for \\\'%s\\\' to feature: \', [permission.toUpperCase(), userName]);
					}'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end