#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\s+(?=(?:(?!%}|\{%).)*%\})"
Local $sString = "{% url '" & @CRLF & _
" someURL" & @CRLF & _
" ' %}" & @CRLF & _
"" & @CRLF & _
"{% extends "layout.html" %}" & @CRLF & _
"" & @CRLF & _
"{% block title %}Page Not found{% endblock %}" & @CRLF & _
"" & @CRLF & _
"{% block content %}" & @CRLF & _
" <p>This is not the page you were looking for.</p>" & @CRLF & _
"{% endblock content %}"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)