$re = '/\s+(?=(?:(?!%}|\{%).)*%\})/s';
$str = '{% url \'
someURL
\' %}
{% extends "layout.html" %}
{% block title %}Page Not found{% endblock %}
{% block content %}
<p>This is not the page you were looking for.</p>
{% endblock content %}';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;