using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?=(?:(?!%}|\{%).)*%\})";
string substitution = @" ";
string input = @"{% url '
someURL
' %}
{% extends ""layout.html"" %}
{% block title %}Page Not found{% endblock %}
{% block content %}
<p>This is not the page you were looking for.</p>
{% endblock content %}";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}