import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(?=(?:(?!%\\}|\\{%).)*%\\})";
final String string = "{% url '\n"
+ " someURL\n"
+ " ' %}\n\n"
+ "{% extends \"layout.html\" %}\n\n"
+ "{% block title %}Page Not found{% endblock %}\n\n"
+ "{% block content %}\n"
+ " <p>This is not the page you were looking for.</p>\n"
+ "{% endblock content %}";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}