const regex = /\s+(?=(?:(?!%}|\{%).)*%\})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(?=(?:(?!%}|\\{%).)*%\\})', 'gs')
const str = `{% url '
someURL
' %}
{% extends "layout.html" %}
{% block title %}Page Not found{% endblock %}
{% block content %}
<p>This is not the page you were looking for.</p>
{% endblock content %}`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);