#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<img[^>]+src=(\"|')([^\"']+)(\"|')[^>]*>"
Local $sString = "<h1>My main item</h1>" & @CRLF & _
"<img src="http://www.blah.com/My First Image Here.jpg">" & @CRLF & _
"<h2>Some extra data</h2>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")