using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]+src=(\""|')([^\""']+)(\""|')[^>]*>";
string input = @"<h1>My main item</h1>
<img src=""http://www.blah.com/My First Image Here.jpg"">
<h2>Some extra data</h2>";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}