const regex = /<img[^>]+src=(\"|')([^\"']+)(\"|')[^>]*>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[^>]+src=(\\"|\')([^\\"\']+)(\\"|\')[^>]*>', 'i')
const str = `<h1>My main item</h1>
<img src="http://www.blah.com/My First Image Here.jpg">
<h2>Some extra data</h2>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}